Azure Service Issues
Incident Report for Cognito Forms
Resolved
We have now confirmed that Microsoft Azure has officially resolved this issue, you should no longer have any issues logging in, or accessing your forms.
Posted May 02, 2019 - 20:18 EDT
Identified
Our hosting platform, Microsoft Azure, is currently experiencing a network outage due to DNS resolution issues. At this time, some Cognito Forms customers may be experiencing difficulties accessing our website and/or forms. We will continue to monitor Azure services and provide updates here.
Posted May 02, 2019 - 16:50 EDT
This incident affected: Website and Forms.