Exporting Entries and Downloading Files Delay
Incident Report for Cognito Forms
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 15:09 EDT
Monitoring
Our engineers have released a fix for this and we will continue monitoring.
Posted Jul 26, 2024 - 13:54 EDT
Identified
The issue has been identified and a fix is being worked on.
Posted Jul 26, 2024 - 12:16 EDT
Investigating
Users may experience delays when exporting entries or downloading files from the Entries page. The export or download should be completed and you'll receive an email once this is complete.

Our engineers are actively looking into addressing this issue and we'll keep you updated as we know more.
Posted Jul 26, 2024 - 12:12 EDT