Viewing Entry Data
Incident Report for Cognito Forms
Resolved
This incident has been resolved.
Posted Jan 25, 2021 - 14:32 EST
Identified
We have identified the issue and directly contacted all affected organizations.
Posted Jan 25, 2021 - 11:30 EST
Investigating
We are actively investigating reports of customers not being able to view some entries from a form's Entries page.
Posted Jan 25, 2021 - 07:30 EST
This incident affected: Website and Forms.