Email outage
Incident Report for Cognito Forms
Resolved
This incident has been resolved.
Posted Jun 14, 2023 - 17:36 EDT
Monitoring
Thanks for your patience. Email notifications that were not initially sent during the outage time frame have now been sent.
Posted Jun 14, 2023 - 17:10 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 14, 2023 - 15:32 EDT
Identified
Our engineers identified an issue with emails not sending for a short time today. The approximate timeframe is from 10:42am to 11:28 am EDT (14:42 - 15:28 UTC). The outage has been resolved and emails sent after 11:28 am are sending normally.

Our engineers are working to requeue the emails that didn't send during this timeframe. We will keep you updated.
Posted Jun 14, 2023 - 13:20 EDT
This incident affected: Email.