Server slowness
Incident Report for Cognito Forms
Resolved
Services should be now back to normal for all Cognito Forms users. We will continue to monitor the situation.
Posted Jun 15, 2020 - 19:02 EDT
Identified
Users may be seeing slow server response times. We are currently working on the issue and expect to see a resolution shortly.
Posted Jun 15, 2020 - 17:22 EDT
This incident affected: Website and Forms.