Email delay
Incident Report for Cognito Forms
Resolved
Email deliverability should be now back to normal for all users. Thank you for your patience!
Posted Apr 02, 2021 - 08:48 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 02, 2021 - 08:08 EDT
Identified
We are actively investigating an email delivery delay affecting most Cognito Forms customers. Normal services will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted Apr 02, 2021 - 08:07 EDT
This incident affected: Email.