Partial Email Outage
Incident Report for Cognito Forms
Resolved
Email services should be back to normal for all Cognito Forms users. We apologize for any inconvenience.
Posted Dec 11, 2018 - 08:55 EST
Investigating
We are actively investigating an outage affecting email deliverability for some Cognito Forms customers. Normal services will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted Dec 11, 2018 - 07:05 EST
This incident affected: Email.