Website Outage

Incident Report for Cognito Forms

Resolved

This incident has been resolved. We’ve identified and are implementing safeguards to help prevent similar issues in the future. Thank you for your patience and understanding.
Posted Apr 01, 2025 - 15:53 EDT

Monitoring

The issue has been fully resolved, and the website is performing normally. We’re continuing to monitor closely and are reviewing options to prevent similar issues in the future. Thank you for your patience.
Posted Apr 01, 2025 - 15:13 EDT

Identified

We experienced degraded performance due to an unexpected spike in traffic that impacted server availability. Our team has identified the root cause and is actively working to restore full performance.
Posted Apr 01, 2025 - 14:57 EDT

Investigating

We are currently investigating reports of an outage affecting the ability for some customers to access our website.
Posted Apr 01, 2025 - 14:40 EDT
This incident affected: Website and Forms.