Partial Server Outage
Incident Report for Cognito Forms
Resolved
Services should be now back to normal for all Cognito Forms users. We apologize for any inconvenience.
Posted Jun 06, 2018 - 15:48 EDT
Investigating
We are currently investigating a server issue affecting a number of Cognito Forms customers. We are working to resolve the issue as quickly as possible - thank you for your patience during this time.
Posted Jun 06, 2018 - 13:59 EDT
This incident affected: Website and Forms.