Email Outage
Incident Report for Cognito Forms
Resolved
We have identified and resolved the issue affecting email deliverability, and services should be now back to normal for all users. Thank you for your patience!
Posted Sep 18, 2019 - 08:10 EDT
Monitoring
We are still actively investigating the cause of the service outage, but emails should now be sending out correctly. You might see an email delay while we continue to work on this service outage.
Posted Sep 17, 2019 - 15:08 EDT
Investigating
We are actively investigating a service outage affecting a number of customers and their forms. Normal services will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted Sep 17, 2019 - 12:37 EDT
This incident affected: Email.