Email Delay

Incident Report for Cognito Forms

Resolved

Notification emails are now sending as normal. All queued emails are being processed and delivered. We appreciate your patience during this time.
Posted Jul 14, 2025 - 09:39 EDT

Monitoring

We’ve implemented a fix for the email delay issue and are currently monitoring the results to ensure everything is working as expected.
Posted Jul 14, 2025 - 09:10 EDT

Update

We are continuing to work on a fix for this issue. We apologize for the delay and thank you for your patience.
Posted Jul 14, 2025 - 08:45 EDT

Identified

We’ve identified an issue causing email notification delays for a small group of customers and are actively working to restore normal email operations.
Posted Jul 13, 2025 - 22:50 EDT
This incident affected: Email.