Email Delay
Incident Report for Cognito Forms
Resolved
Email deliverability should be now back to normal for all users. Thank you for your patience!
Posted Jun 16, 2020 - 17:41 EDT
Monitoring
Emails have been delayed due to the Server Incident earlier on 6/16/2020. Emails have been queued and are being sent out.
Posted Jun 16, 2020 - 16:31 EDT