Email Delay
Incident Report for Cognito Forms
Resolved
This issue has been resolved, and emails should be sending normally.
Posted Mar 23, 2021 - 15:08 EDT
Identified
Email notifications are currently experiencing a delay. Normal email delivery will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted Mar 23, 2021 - 13:54 EDT
This incident affected: Email.