Partial Email Outage
Incident Report for Cognito Forms
Resolved
Email services are back to normal for all Cognito Forms users. We apologize for any inconvenience.
Posted Oct 29, 2018 - 15:54 EDT
Identified
One of our email providers, Mandrill, is currently resolving connection issues that may be affecting email deliverability for some Cognito Forms customers. We will continue to monitor email services and provide updates here.
Posted Oct 29, 2018 - 13:51 EDT
Investigating
We are actively investigating an outage affecting email deliverability for a number of Cognito Forms customers. Normal services will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted Oct 29, 2018 - 13:12 EDT
This incident affected: Email.