Email Outage
Incident Report for Cognito Forms
Resolved
Email delivery should be now back to normal for all users. Thank you for your patience!
Posted Feb 06, 2019 - 09:06 EST
Monitoring
Our email solution is in place and automated emails should be flowing as usual. If you experience any email delays or outages, please let us know. https://www.cognitoforms.com/support
Posted Feb 05, 2019 - 16:41 EST
Identified
One of our email providers is having a major outage. Because of this, it’s possible that some of our customers’ automated emails may be delayed. We’re currently testing solutions to quickly minimize and eliminate any impact to Cognito Forms customers.
Posted Feb 05, 2019 - 14:53 EST
Investigating
We are actively investigating an email delay affecting a number of customers. Normal services will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted Feb 05, 2019 - 09:07 EST
This incident affected: Email.