Issues with Stripe Payments
Incident Report for Cognito Forms
Resolved
We have released a hotfix to address issues with some payments returning a 'Card is invalid' error message when a form is connected to Stripe for payment. We apologize for any inconvenience.
Posted Aug 19, 2019 - 19:25 EDT
Identified
We have identified an issue affecting some customers that use Stripe for payment on their forms. This issue would cause some payments to return an error 'Card is invalid'. Our developers are currently deploying a hotfix to address this problem.
Posted Aug 19, 2019 - 17:57 EDT
This incident affected: Website and Forms.