Server Incident
Incident Report for Cognito Forms
Resolved
We have identified and resolved the issue, and services should be now back to normal for all users. We will continue to monitor the situation that caused a partial service outage. Thank you for your patience!
Posted Jun 25, 2020 - 10:35 EDT
Identified
We have identified the issue that is causing partial service outage affecting a small number of customers and their forms. Normal services will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted Jun 25, 2020 - 09:43 EDT
Investigating
We are actively investigating a partial service outage affecting a small number of customers and their forms. Normal services will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted Jun 25, 2020 - 09:16 EDT