Email Delay
Incident Report for Cognito Forms
Resolved
Email delivery should be now back to normal for all users. Thank you for your patience!
Posted May 02, 2019 - 20:16 EDT
Monitoring
We are actively monitoring an email delivery delay that we are seeing with one of our email provider. Normal email delivery will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted May 02, 2019 - 15:07 EDT
This incident affected: Email.