Server Incident
Incident Report for Cognito Forms
Resolved
Services should be now back to normal for all users. Thank you for your patience!
Posted May 26, 2020 - 12:39 EDT
Monitoring
Services should be now back to normal for all Cognito Forms users. We will continue to monitor the situation.
Posted May 26, 2020 - 11:35 EDT
Investigating
We are actively investigating a service outage affecting a number of customers and their forms. Normal services will resume as quickly as possible; we apologize for any inconvenience this may cause.
Posted May 26, 2020 - 10:34 EDT
This incident affected: Website and Forms.