Square is Experiencing Outages
Incident Report for Cognito Forms
Resolved
This issue has been resolved. Please contact support if you are experiencing any ongoing issues with Square payments on your forms.
Posted Sep 08, 2023 - 08:12 EDT
Update
Square is continuing to look into issues with processing payments. We will continue to keep you updated as we know more. Please click the link below for the most up-to-date status from Square:
https://www.issquareup.com/
Posted Sep 07, 2023 - 20:35 EDT
Update
Square is continuing to look into issues with processing payments. Click the link below for the most up-to-date status from Square:
https://www.issquareup.com/
Posted Sep 07, 2023 - 18:28 EDT
Identified
Square is currently experiencing issues with processing payments. Cognito Forms connected to Square will not be able to process payments.
You can click the link below to view Square's status page related to this:
https://www.issquareup.com/
Posted Sep 07, 2023 - 16:38 EDT
This incident affected: Integrations.